aur-packages/heptagon-git/PKGBUILD
2024-10-02 14:39:50 +02:00

38 lines
897 B
Bash

# Maintainer: Mylloon <kennel.anri@tutanota.com>
# shellcheck disable=SC2034,SC2148,SC2154
pkgname='heptagon-git'
pkgver=r1220.b169c545
pkgrel=1
pkgdesc="Heptagon is a synchronous dataflow programming language"
arch=('x86_64')
url=https://gitlab.inria.fr/synchrone/heptagon
license=('GPL-3.0-only')
makedepends=('git' 'ocaml' 'ocaml-findlib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+https://gitlab.inria.fr/synchrone/heptagon.git")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}" || exit
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "$srcdir/${pkgname%-git}" || exit
opam install -y menhir ocamlgraph camlp4
}
build() {
cd "$srcdir/${pkgname%-git}" || exit
eval "$(opam env)"
./configure
make
make install
}
package() {
cd "${srcdir}/${pkgname%-git}" || exit
}